1. UAVHub Frequently Asked Questions (FAQ's)
  2. Examity - Online Examination System FAQs

Why is the Examity systems checker asking for me to install Flash

You are not using the correct browser. If you are running a macOS device, please use Firefox only

Examity is NOT compatible with Safari, which throws up an error regarding installing Flash which is now a redundant piece of software.

If you are running the examination on macOC you MUST use Firefox to take the examination. The examination is not compatible with Safari and it is only partially compatible with Chrome on macOS.